desenv-web-rp.com

no frontend não recebi nada além de um sinal ">"

Acabei de criar meu site offline e, quando tentei fazê-lo online, não consegui nada além de um sinal de ">" na página. Recebi o back-end do site corretamente, mas não sei o que aconteceu com o front-end. quando mudei o modelo para o modelo padrão, o problema foi resolvido. E quando mudo o relatório de erros para o modo de desenvolvimento, recebi muito desse erro:

Padrões estritos: Somente variáveis ​​devem ser atribuídas por referência em /home/alitk/public_html/modules/mod_news_pro_gk4/helper.php na linha 553

e

Padrões estritos: O método não estático NSP_GK4_Thumbs :: checkSpecialImages () não deve ser chamado estaticamente, assumindo $ this do contexto incompatível em /home/alitk/public_html/modules/mod_news_pro_gk4/gk_classes/gk.thumbs.php na linha 127

1
user23047

Você tem uma configuração diferente entre o seu desenvolvimento e o seu site de produção. Ao migrar de um local para outro, você pode encontrar erros fatais. Você precisa verificar todos os requisitos do sistema no novo servidor.

Por exemplo, a extensão ionCube, usada em algumas extensões comerciais fechadas, é uma surpresa desagradável comum.

Para resolver o problema, eu começaria a desativar os plug-ins de sistema não essenciais, um por um, até a página ser carregada com êxito. Caso contrário, tente desinstalar todas as extensões para restringir a pesquisa, mesmo se você precisar voltar para um dos modelos padrão. Depois de encontrar o problema, você cria um backup modificado no site de desenvolvimento.

1
Anibal

Você pode tentar várias coisas para encontrar o problema e, sem realmente ver o site, é difícil saber o que está causando isso.

quando mudei o modelo para o modelo padrão, o problema foi resolvido.

Isso indica que o problema pode estar no seu modelo.

  1. Se possível, faça o upload do site inteiro novamente, para garantir que todos os arquivos foram transferidos corretamente. Sugiro usar Akeeba Backup ao mover seu site para outro servidor.
  2. Verifique se o Joomla e suas extensões estão atualizados, bem como o modelo que você está usando.
  3. Como Anibal apontou, seus servidores podem ter configurações diferentes. Verifique e compare PHP e versões do MySQL em seus servidores.
  4. Desative/cancele a publicação de seus plugins e módulos, um por um, caso algum deles entre em conflito com seu modelo.
1
johanpw